Commit c5be0226 authored by Jason Helfman's avatar Jason Helfman
Browse files

dns/dnsdist: drop i386 support, adjust configure arguments and deps

PR:		255841
Reported by:	maintainer (tremere@cainites.net)
parent 0aafc89d
......@@ -2,6 +2,7 @@
PORTNAME= dnsdist
DISTVERSION= 1.6.0
PORTREVISION= 1
CATEGORIES= dns net
MASTER_SITES= https://downloads.powerdns.com/releases/
......@@ -14,10 +15,12 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
LICENSE_FILE_ISCL= ${WRKSRC}/ext/ipcrypt/LICENSE
LICENSE_FILE_MIT= ${WRKSRC}/ext/yahttp/LICENSE
NOT_FOR_ARCHS= i386
NOT_FOR_ARCHS_REASON= archs with 32-bits time_t are no longer supported by upstream
BUILD_DEPENDS= ${LOCALBASE}/lib/libatomic_ops.a:devel/libatomic_ops
LIB_DEPENDS= libboost_serialization.so:devel/boost-libs \
libh2o-evloop.so:www/h2o \
libprotobuf.so:devel/protobuf \
libre2.so:devel/re2 \
libsodium.so:security/libsodium
......@@ -61,10 +64,10 @@ CDB_CONFIGURE_ON= CDB_CFLAGS="-I${LOCALBASE}/include" \
CDB_LIBS="-L${LOCALBASE}/lib -lcdb"
DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm
DNSTAP_CONFIGURE_ENABLE= fstrm
DNSTAP_CONFIGURE_ENABLE= dnstap
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_CONFIGURE_ENABLE= gnutls
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_CONFIGURE_WITH= gnutls
LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
LMDB_CONFIGURE_ON= --with-lmdb=${LOCALBASE}
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment