Commit 6a294c20 authored by cvs2svn's avatar cvs2svn
Browse files

This commit was manufactured by cvs2svn to create tag 'RELEASE_5_1_0'.

parent ef70e981
This diff is collapsed.
#
# $FreeBSD$
#
# This file contains some variable definitions that are supposed to
# make your life easier when dealing with ports related to the GNUstep.
#
#
# Options for user to customize in /etc/make.conf:
# ================================================
#
# WITH_GNUSTEP_XDPS=yes
# use xdps as backend instead of xlib.
#
# WITH_GNUSTEP_LIBART=yes
# use libart as backend instead of xlib.
#
#
# Options for a port before include this file:
# ============================================
#
# USE_GNUSTEP_BASE=yes
# your port depends on the gnustep-base port.
#
# USE_GNUSTEP_GUI=yes
# your port depends on the gnustep-gui port.
#
# USE_GNUSTEP_BACK=yes
# your port depends on teh gnustep-back port.
#
# USE_GNUSTEP_CONFIGURE=yes
# call configure script with GNUstep.sh sourced in the current shell
#
# USE_GNUSTEP_BUILD=yes
# call build target with GNUstep.sh sourced in the current shell
#
# USE_GNUSTEP_INSTALL=yes
# call install target with GNUstep.sh sourced in the current shell
#
# ---------------------------------------------------------------------------
.if !defined(_POSTMKINCLUDED)
GNUstep_Include_MAINTAINER= dinoex@FreeBSD.org
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall
LIB_DEPENDS+= objc:${PORTSDIR}/${GNUSTEP_OBJC_PORT}
GNUSTEP_MAKE_PORT?= devel/gnustep-make
GNUSTEP_OBJC_PORT?= lang/gnustep-objc
GNUSTEP_BASE_PORT?= lang/gnustep-base
GNUSTEP_GUI_PORT?= x11-toolkits/gnustep-gui
GNUSTEP_BACK_PORT?= x11-toolkits/gnustep-back
GNUSTEP_XDPS_PORT?= x11-toolkits/gnustep-xdps
GNUSTEP_ART_PORT?= x11-toolkits/gnustep-art
.if ${MACHINE_ARCH} == "i386"
GNU_ARCH= ix86
.else
GNU_ARCH= ${MACHINE_ARCH}
.endif
PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION}
PLIST_SUB+= MAJORVERSION=${PORTVERSION:C/([0-9]).*/\1/1}
SYSTEMDIR= ${PREFIX}/System
SYSMAKEDIR= ${SYSTEMDIR}/Makefiles
SYSLIBDIR= ${SYSTEMDIR}/Libraries/${GNU_ARCH}/${OPSYS:L}
COMBOLIBDIR= ${SYSTEMDIR}/Libraries/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu
BUNDLEDIR= ${SYSTEMDIR}/Library/Bundles
COMBOPATH= ${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu
LOCALLIBDIR= ${PREFIX}/Local/Libraries/${COMBOPATH}
CC= gcc32
CXX= g++32
# ---------------------------------------------------------------------------
# using base
#
.if defined(USE_GNUSTEP_BASE)
BUILD_DEPENDS+= ${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/${GNUSTEP_BASE_PORT}
RUN_DEPENDS+= ${COMBOLIBDIR}/libgnustep-base.so:${PORTSDIR}/${GNUSTEP_BASE_PORT}
.endif
# ---------------------------------------------------------------------------
# using gui
#
.if defined(USE_GNUSTEP_GUI)
BUILD_DEPENDS+= ${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/${GNUSTEP_GUI_PORT}
RUN_DEPENDS+= ${COMBOLIBDIR}/libgnustep-gui.so:${PORTSDIR}/${GNUSTEP_GUI_PORT}
.endif
# ---------------------------------------------------------------------------
# using any backend
#
.if defined(USE_GNUSTEP_BACK)
.if defined(WITH_GNUSTEP_XDPS)
GNUSTEP_WITH_XDPS=yes
.else
.if defined(WITH_GNUSTEP_LIBART)
USE_GNUSTEP_LIBART=yes
.else
USE_GNUSTEP_XLIB=yes
.endif
.endif
.endif
# ---------------------------------------------------------------------------
# Backend using xlib
#
.if defined(USE_GNUSTEP_XLIB)
BUILD_DEPENDS+= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/${GNUSTEP_BACK_PORT}
RUN_DEPENDS+= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/${GNUSTEP_BACK_PORT}
BACKBUNDLEDIR= ${BUNDLEDIR}/libgnustep-back.bundle/${COMBOPATH}
MAKE_FLAGS+= GUI_BACKEND_LIB=back
.endif
# ---------------------------------------------------------------------------
# Backend using xdps
#
.if defined(USE_GNUSTEP_XDPS)
BUILD_DEPENDS+= ${BACKBUNDLEDIR}/libgnustep-xdps:${PORTSDIR}/${GNUSTEP_XDPS_PORT}
RUN_DEPENDS+= ${BACKBUNDLEDIR}/libgnustep-xdps:${PORTSDIR}/${GNUSTEP_XDPS_PORT}
BACKBUNDLEDIR= ${BUNDLEDIR}/libgnustep-xdps.bundle/${COMBOPATH}
MAKE_FLAGS+= GUI_BACKEND_LIB=xdps
.endif
# ---------------------------------------------------------------------------
# Backend using libart
#
.if defined(USE_GNUSTEP_LIBART)
BUILD_DEPENDS+= ${BACKBUNDLEDIR}/libgnustep-art:${PORTSDIR}/${GNUSTEP_ART_PORT}
RUN_DEPENDS+= ${BACKBUNDLEDIR}/libgnustep-art:${PORTSDIR}/${GNUSTEP_ART_PORT}
BACKBUNDLEDIR= ${BUNDLEDIR}/libgnustep-art.bundle/${COMBOPATH}
MAKE_FLAGS+= GUI_BACKEND_LIB=art
.endif
# ---------------------------------------------------------------------------
# source GNUstep.sh
#
.if defined(USE_GNUSTEP_CONFIGURE)
do-configure:
@(cd ${CONFIGURE_WRKSRC}; . ${SYSMAKEDIR}/GNUstep.sh; \
if ! ${SETENV} CC="${CC}" CXX="${CXX}" \
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
INSTALL="/usr/bin/install -c -o ${BINOWN} -g ${BINGRP}" \
INSTALL_DATA="${INSTALL} -c" \
INSTALL_PROGRAM="${INSTALL} -c" \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}; then \
${ECHO} "===> Script \"${CONFIGURE_SCRIPT}\" failed: here are the contents of \"${CONFIGURE_LOG}\""; \
${CAT} ${CONFIGURE_LOG}; \
${ECHO} "(end of \"${CONFIGURE_LOG}\")"; \
${FALSE}; \
fi)
.endif
# ---------------------------------------------------------------------------
# source GNUstep.sh
#
.if defined(USE_GNUSTEP_BUILD)
BUILD_DEPENDS+= ${SYSMAKEDIR}/GNUstep.sh:${PORTSDIR}/${GNUSTEP_MAKE_PORT}
do-build:
@(cd ${WRKSRC}; . ${SYSMAKEDIR}/GNUstep.sh; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
.endif
# ---------------------------------------------------------------------------
# source GNUstep.sh
#
.if defined(USE_GNUSTEP_INSTALL)
RUN_DEPENDS+= ${SYSMAKEDIR}/GNUstep.sh:${PORTSDIR}/${GNUSTEP_MAKE_PORT}
do-install:
@(cd ${WRKSRC}; . ${SYSMAKEDIR}/GNUstep.sh; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
.endif
.endif
# eof
#-*- mode: Makefile; tab-width: 4; -*-
# ex:ts=4
#
# $FreeBSD$
#
# Please view me with 4 column tabs!
# Please make sure all changes to this file are past through the maintainer.
# Do not commit them yourself (unless of course you're the Port's Wraith ;).
KDE_MAINTAINER= will@FreeBSD.org
# This section contains the USE_ definitions.
# XXX: Write HAVE_ definitions sometime.
# USE_QT_VER - Says that the port uses the Qt toolkit. Possible values:
# 1, 2, or 3; each specify the major version of Qt to use.
# USE_KDELIBS_VER - Says that the port uses KDE libraries. Possible values:
# 1, 2, or 3; each specify the major version of KDE to use.
# This implies USE_QT of the appropriate version.
# USE_KDEBASE_VER - Says that the port uses the KDE base. Possible values:
# 1, 2, or 3; each specify the major version of KDE to use.
# This implies USE_KDELIBS of the appropriate version.
#
# WARNING! ACHTUNG! DANGER WILL ROBINSON!
# DO NOT USE USE_QT_VER=1 UNLESS YOU WILL NOT BE NEEDING ANY ASSISTANCE
# WHATSOEVER FROM THE MAINTAINER OF THIS FILE!
#
# Compat shims.
.if defined(USE_QT)
USE_QT_VER= 2
pre-everything::
@${ECHO} ">>> Warning: this port needs to be updated as it uses the old-style USE_QT variable!"
.endif # defined(USE_QT)
.if defined(USE_QT2)
USE_QT_VER= 2
pre-everything::
@${ECHO} ">>> Warning: this port needs to be updated as it uses the old-style USE_QT2 variable!"
.endif # defined(USE_QT2)
# tagged MASTER_SITE_KDE_kde
kmaster= ${MASTER_SITE_KDE:S@%/@%/:kde@g}
.if !defined(MASTER_SITE_SUBDIR)
MASTER_SITE_KDE_kde= ${kmaster:S@%SUBDIR%/@@g}
.else
ksub=${MASTER_SITE_SUBDIR}
MASTER_SITE_KDE_kde= ${kmaster:S@%SUBDIR%/@${ksub}/@g}
.endif # !defined(MASTER_SITE_SUBDIR)
# USE_KDEBASE_VER section
.if defined(USE_KDEBASE_VER)
.if ${USE_KDEBASE_VER} == 3
# kdebase 3.x common stuff
LIB_DEPENDS+= konq:${PORTSDIR}/x11/kdebase3
USE_KDELIBS_VER=3
.else
# kdebase 2.x common stuff -- DEFAULT
USE_KDELIBS_VER=2
.endif # ${USE_KDEBASE_VER} == 3
.endif # defined(USE_KDEBASE_VER)
# USE_KDELIBS_VER section
.if defined(USE_KDELIBS_VER)
.if ${USE_KDELIBS_VER} == 3
# kdelibs 3.x common stuff
LIB_DEPENDS+= kdecore:${PORTSDIR}/x11/kdelibs3
USE_QT_VER= 3
PREFIX= ${KDE_PREFIX}
.else
BROKEN= "KDE2 is gone. This port needs to be updated or deleted!"
# kdelibs 2.x common stuff -- DEFAULT
USE_QT_VER= 2
.endif # ${USE_KDELIBS_VER} == 3
.endif # defined(USE_KDELIBS_VER)
# End of USE_KDELIBS_VER section
# USE_QT_VER section
.if defined(USE_QT_VER)
# Qt 1.x common stuff
.if ${USE_QT_VER} == 1
LIB_DEPENDS+= qt1.3:${PORTSDIR}/x11-toolkits/qt145
MOC?= ${X11BASE}/bin/moc1
.if defined(PREFIX)
QTDIR= ${PREFIX}
.else
QTDIR= ${X11BASE}
.endif # defined(PREFIX)
CONFIGURE_ENV+= MOC="${MOC}" QTDIR="${QTDIR}"
.elif ${USE_QT_VER} == 3
# Yeah, it's namespace pollution, but this is really the best place for this
# stuff. Arts does NOT use it anymore.
KDE_VERSION= 3.1.2
KDE_ORIGVER= ${KDE_VERSION}
KDE_PREFIX?= ${LOCALBASE}
QTCPPFLAGS?=
QTCGFLIBS?=
# Qt 3.x common stuff
QT_PREFIX?= ${X11BASE}
MOC?= ${QT_PREFIX}/bin/moc
#LIB_DEPENDS+= qt-mt.3:${PORTSDIR}/x11-toolkits/qt31
BUILD_DEPENDS+= ${QT_PREFIX}/bin/moc:${PORTSDIR}/x11-toolkits/qt31
RUN_DEPENDS+= ${QT_PREFIX}/bin/moc:${PORTSDIR}/x11-toolkits/qt31
QTCPPFLAGS+= -I${LOCALBASE}/include -I${PREFIX}/include \
-I${QT_PREFIX}/include -D_GETOPT_H
QTCFGLIBS+= -Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -ljpeg \
-L${QT_PREFIX}/lib
.if !defined(QT_NONSTANDARD)
CONFIGURE_ARGS+=--with-qt-includes=${QT_PREFIX}/include \
--with-qt-libraries=${QT_PREFIX}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= MOC="${MOC}" CPPFLAGS="${QTCPPFLAGS}" LIBS="${QTCFGLIBS}"
.endif # !defined(QT_NONSTANDARD)
.else # QT2
QTCPPFLAGS?=
QTCGFLIBS?=
# Qt 2.x common stuff -- DEFAULT
LIB_DEPENDS+= qt2.4:${PORTSDIR}/x11-toolkits/qt23
QTNAME= qt2
MOC?= ${X11BASE}/bin/moc2
QTCPPFLAGS+= -D_GETOPT_H -I${LOCALBASE}/include -I${PREFIX}/include \
-I${X11BASE}/include/qt2
QTCFGLIBS+= -Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -ljpeg -lgcc -lstdc++
.if !defined(QT_NONSTANDARD)
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-l${QTNAME}" \
CPPFLAGS="${QTCPPFLAGS}" LIBS="${QTCFGLIBS}"
.endif # !defined(QT_NONSTANDARD)
.endif # USE_QT_VER == ???
.endif # defined(USE_QT_VER)
# End of USE_QT_VER section
# Assemble plist from parts
# <alane@freebsd.org> 2002-12-06
.if defined(KDE_BUILD_PLIST)
PLIST?= ${WRKDIR}/plist
PLIST_BASE?= plist.base
PLIST_APPEND?=
plist_base=${FILESDIR}/${PLIST_BASE}
plist_base_rm=${FILESDIR}/${PLIST_BASE}.rm
plist_append=${PLIST_APPEND:C:([A-Za-z0-9._]+):${FILESDIR}/\1:}
plist_append_rm=${PLIST_APPEND:C:([A-Za-z0-9._]+):${FILESDIR}/\1.rm:}
kde-plist:
${CAT} ${plist_base} ${plist_append} 2>/dev/null >${PLIST}
-${CAT} ${plist_append_rm} ${plist_base_rm} 2>/dev/null >>${PLIST};true
.PHONY: kde-plist
pre-build: kde-plist
.endif # defined(KDE_BUILD_PLIST)
# makefile for use of: OpenSSH
# Date created: 31 May 2002
# Whom: dinoex
#
# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.openssl.mk,v 1.5 2003-05-07 20:08:00 dinoex Exp $
#
# this substitutes USE_OPENSSL=yes
# just include this makefile after bsd.ports.pre.mk
#
# the user/port can now set this options in the makefiles.
#
# WITH_OPENSSL_BASE=yes - Use the version in the base system.
# WITH_OPENSSL_PORT=yes - Use the port, even if base if up to date
# WITH_OPENSSL_BETA=yes - Use a snapshot of recent openssl
#
# Overrideable defaults:
#
# OPENSSL_SHLIBVER= 3
# OPENSSL_PORT= security/openssl
#
# The makefile sets this variables:
# OPENSSLBASE - "/usr" or ${LOCALBASE}
# OPENSSLDIR - path to openssl
# OPENSSLLIB - path to the libs
# OPENSSLINC - path to the matching includes
#
# MAKE_ENV - extended with the variables above
# LIB_DEPENDS - are added if needed
# honor obsolete options for a bit
.if defined(USE_OPENSSL_BASE) && !defined(WITH_OPENSSL_BASE)
WITH_OPENSSL_BASE=yes
.endif
.if defined(USE_OPENSSL_PORT) && !defined(WITH_OPENSSL_PORT)
WITH_OPENSSL_PORT=yes
.endif
# if no preference was set, check for an up to date base version
# but give an installed port preference over it.
.if !defined(WITH_OPENSSL_BASE) && \
!defined(WITH_OPENSSL_BETA) && \
!defined(WITH_OPENSSL_PORT) && \
!exists(${LOCALBASE}/lib/libcrypto.so) && \
exists(/usr/include/openssl/opensslv.h)
# Security: version in base must be 0.9.7a
OPENSSLVER!= ${AWK} '/OPENSSL_VERSION_NUMBER/ { print $$3 }' \
/usr/include/openssl/opensslv.h
.if ${OPENSSLVER} == 0x0090701fL || ${OPENSSLVER} == 0x0090702fL
WITH_OPENSSL_BASE=yes
.endif
.endif
.if defined(WITH_OPENSSL_BASE)
OPENSSLBASE= /usr
OPENSSLDIR= /etc/ssl
.if !exists(/usr/lib/libcrypto.so)
.BEGIN:
@${ECHO_CMD} "This port requires the OpenSSL library, which is part of"
@${ECHO_CMD} "the FreeBSD crypto distribution but not installed on your"
@${ECHO_CMD} "machine. Please see the \"OpenSSL\" section in the handbook"
@${ECHO_CMD} "(at \"http://www.FreeBSD.org/doc/en_US.ISO8859-1/books/handbook/openssl.html\", for instance)"
@${ECHO_CMD} "for instructions on how to obtain and install the FreeBSD"
@${ECHO_CMD} "OpenSSL distribution."
@${FALSE}
.endif
.if exists(${LOCALBASE}/lib/libcrypto.so)
.BEGIN:
@${ECHO_CMD} "This port wants the OpenSSL library from the FreeBSD"
@${ECHO_CMD} "base system. You can't build against it, while a newer"
@${ECHO_CMD} "Version is installed by a port."
@${ECHO_CMD} "Please deinstall the port or undefine WITH_OPENSSL_BASE."
@${FALSE}
.endif
# OpenSSL in the base system may not include IDEA for patent licensing reasons.
.if defined(MAKE_IDEA) && !defined(OPENSSL_IDEA)
OPENSSL_IDEA= ${MAKE_IDEA}
.else
OPENSSL_IDEA?= NO
.endif
.if ${OPENSSL_IDEA} == "NO"
# XXX This is a hack to work around the fact that /etc/make.conf clobbers
# our CFLAGS. It might not be enough for all future ports.
.if defined(HAS_CONFIGURE)
CFLAGS+= -DNO_IDEA
.else
OPENSSL_CFLAGS+= -DNO_IDEA
.endif
MAKE_ARGS+= OPENSSL_CFLAGS="${OPENSSL_CFLAGS}"
.endif
CFLAGS+= -Wl,-rpath,/usr/lib:${LOCALBASE}/lib
OPENSSL_LDFLAGS+= -rpath=/usr/lib:${LOCALBASE}/lib
.else
OPENSSLBASE= ${LOCALBASE}
.if defined(WITH_OPENSSL_BETA)
OPENSSL_SHLIBVER?= 4
OPENSSL_PORT?= security/openssl-beta
.else
OPENSSL_SHLIBVER?= 3
OPENSSL_PORT?= security/openssl
.endif
OPENSSLDIR= ${OPENSSLBASE}/openssl
LIB_DEPENDS+= crypto.${OPENSSL_SHLIBVER}:${PORTSDIR}/${OPENSSL_PORT}
CFLAGS+= -Wl,-rpath,${LOCALBASE}/lib
OPENSSL_LDFLAGS+= -rpath=${LOCALBASE}/lib
.endif
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
OPENSSLBASE=${OPENSSLBASE} OPENSSLDIR=${OPENSSLDIR}
.if defined(LDFLAGS) && !empty(LDFLAGS)
LDFLAGS+=${OPENSSL_LDFLAGS}
.else
LDFLAGS=${OPENSSL_LDFLAGS}
.endif
### crypto
#RESTRICTED= "Contains cryptography."
# New ports collection makefile for: at-spi
# Date Created: 12 April 2002
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= at-spi
PORTVERSION= 1.1.8
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.1
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= An Assistive Technology Service Provider Interface
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier gail libbonobo
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --enable-static
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
MD5 (gnome2/at-spi-1.1.8.tar.bz2) = 76e2df52a280a794bde0e6dd259c01f8
$FreeBSD$
--- Makefile.in.orig Tue Jun 11 03:51:37 2002
+++ Makefile.in Tue Jun 11 03:52:06 2002
@@ -127,7 +127,7 @@
X_LIBS = @X_LIBS@
cxxflags_set = @cxxflags_set@
-SUBDIRS = docs idl libspi registryd atk-bridge cspi test
+SUBDIRS = docs idl libspi registryd atk-bridge cspi
pkgconfigdir = $(prefix)/libdata/pkgconfig
pkgconfig_DATA = libspi-1.0.pc cspi-1.0.pc
$FreeBSD$
--- configure 2002/04/26 13:02:36 1.1
+++ configure 2002/04/26 13:02:46
@@ -6712,6 +6712,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
$FreeBSD$
--- docs/reference/cspi/Makefile.in 2002/04/12 10:18:10 1.1
+++ docs/reference/cspi/Makefile.in 2002/04/12 10:18:49
@@ -146,7 +146,7 @@
INSTALLDIR = $(prefix)/share/gtk-doc
-HTML_DIR = ${datadir}/gtk-doc/html
+HTML_DIR = ${prefix}/share/doc
TARGET_DIR = $(HTML_DIR)/$(DOC_MODULE)
--- registryd/deviceeventcontroller.c.orig Wed Nov 27 16:36:12 2002
+++ registryd/deviceeventcontroller.c Wed Nov 27 16:38:21 2002
@@ -32,6 +32,7 @@
#include <string.h>
#include <ctype.h>
#include <stdio.h>
+#include <sys/time.h>
#include <bonobo/bonobo-exception.h>
#include <X11/Xlib.h>
This is the Early Access Release of the Gnome Accessibility Project's
Assistive Technology Service Provider Interface.
WWW: http://www.gnome.org/
include/at-spi-1.0/cspi/spi-impl.h
include/at-spi-1.0/cspi/spi-listener.h
include/at-spi-1.0/cspi/spi-roletypes.h
include/at-spi-1.0/cspi/spi-statetypes.h
include/at-spi-1.0/cspi/spi.h
include/at-spi-1.0/libspi/Accessibility.h
include/at-spi-1.0/libspi/accessible.h
include/at-spi-1.0/libspi/action.h
include/at-spi-1.0/libspi/application.h
include/at-spi-1.0/libspi/base.h
include/at-spi-1.0/libspi/component.h
include/at-spi-1.0/libspi/devicelistener.h
include/at-spi-1.0/libspi/editabletext.h
include/at-spi-1.0/libspi/eventlistener.h
include/at-spi-1.0/libspi/hyperlink.h
include/at-spi-1.0/libspi/hypertext.h
include/at-spi-1.0/libspi/image.h
include/at-spi-1.0/libspi/keymasks.h
include/at-spi-1.0/libspi/keystrokelistener.h
include/at-spi-1.0/libspi/libspi.h
include/at-spi-1.0/libspi/listener.h
include/at-spi-1.0/libspi/relation.h
include/at-spi-1.0/libspi/remoteobject.h
include/at-spi-1.0/libspi/selection.h
include/at-spi-1.0/libspi/stateset.h
include/at-spi-1.0/libspi/table.h
include/at-spi-1.0/libspi/text.h
include/at-spi-1.0/libspi/value.h
lib/libcspi.a
lib/libcspi.so
lib/libcspi.so.8
lib/libspi.a
lib/libspi.so
lib/libspi.so.8
lib/gtk-2.0/modules/libatk-bridge.so
lib/orbit-2.0/Accessibility_module.so
libdata/bonobo/servers/Accessibility_Registry.server
libdata/pkgconfig/cspi-1.0.pc
libdata/pkgconfig/libspi-1.0.pc
libexec/at-spi-registryd
share/doc/at-spi-cspi/at-spi-cspi-accessible-objects.html
share/doc/at-spi-cspi/at-spi-cspi-accessibleaction-interface.html
share/doc/at-spi-cspi/at-spi-cspi-accessibleapplication-api.html
share/doc/at-spi-cspi/at-spi-cspi-accessiblecomponent-interface.html
share/doc/at-spi-cspi/at-spi-cspi-accessibleeditabletext-interface.html
share/doc/at-spi-cspi/at-spi-cspi-accessiblehyperlink-interface.html
share/doc/at-spi-cspi/at-spi-cspi-accessiblehypertext-interface.html
share/doc/at-spi-cspi/at-spi-cspi-accessibleimage-interface.html
share/doc/at-spi-cspi/at-spi-cspi-accessiblerelations-and-relationsets.html
share/doc/at-spi-cspi/at-spi-cspi-accessibleselection-interface.html
share/doc/at-spi-cspi/at-spi-cspi-accessibletable-interface.html
share/doc/at-spi-cspi/at-spi-cspi-accessibletext-interface.html
share/doc/at-spi-cspi/at-spi-cspi-accessiblevalue-interface.html
share/doc/at-spi-cspi/at-spi-cspi-event-listener-support.html
share/doc/at-spi-cspi/at-spi-cspi-registry-queries.html
share/doc/at-spi-cspi/at-spi-cspi-spi-main-loop-and-initialization.html
share/doc/at-spi-cspi/at-spi-cspi-state-and-statesets.html
share/doc/at-spi-cspi/book1.html
share/doc/at-spi-cspi/c5968.html
share/doc/at-spi-cspi/index.sgml
share/doc/at-spi-cspi/spi-accessible.html