Commit a5727787 authored by Richard Hughes's avatar Richard Hughes
Browse files

Adapt to the dropped API in fwupd 0.5

parent 49e25934
......@@ -158,7 +158,7 @@ fi
AC_ARG_ENABLE(uefi, AS_HELP_STRING([--enable-uefi],[Enable UEFI support]),
enable_uefi=$enableval, enable_uefi=yes)
if test x$enable_uefi != xno; then
PKG_CHECK_MODULES(UEFI, fwup)
PKG_CHECK_MODULES(UEFI, fwup >= 0.5)
AC_DEFINE(HAVE_UEFI,1,[Use ColorHug support])
fi
AM_CONDITIONAL(HAVE_UEFI, test x$enable_uefi = xyes)
......
......@@ -26,7 +26,7 @@ BuildRequires: libappstream-glib-devel >= 0.3.6
BuildRequires: gcab
%ifarch x86_64 %{ix86} aarch64
BuildRequires: fwupdate-devel >= 0.4
BuildRequires: fwupdate-devel >= 0.5
%endif
Requires(post): systemd
......
......@@ -232,7 +232,7 @@ fu_provider_uefi_update (FuProvider *provider,
FWUPD_ERROR,
FWUPD_ERROR_NOT_SUPPORTED,
"UEFI firmware update failed: %s",
fwup_strerror (fwup_error));
strerror (errno));
goto out;
}
out:
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment